OSPF Multi Area

Single-area OSPF design places all routers into a single OSPF area, which results in many LSAs being processed on every router. Fortunately, OSPF allows us to take a large OSPF topology and break it down into multiple, more manageable areas.
 OSPF Single Area
 OSPF Multi Area

OSPF Neighbourship Message

1. Hello
2. DBD
3. LSR (Link state request)
4. LSU (Link state update)
5. LSA (Link statecAcknoledgement)

OSPF routers keep track of the status of links within their respective areas. A link is simply a router interface. From these lists of links and their respective statuses, the topology database is created. OSPF routers forward link-state advertisements (LSAs) to ensure the topology database is consistent on each router within an area.

Several LSA types exist:
• Router LSA (Type 1) – Contains a list of all links local to the router, and the status and “cost” of those links. Type 1 LSAs are generated by all routers in OSPF, and are flooded to all other routers within the local area.

• Network LSA (Type 2) – Generated by all Designated Routers in OSPF, and contains a list of all routers attached to the Designated Router.

• Network Summary LSA (Type 3) – Generated by all ABRs in OSPF, and contains a list of all destination networks within an area. Type 3 LSAs are sent between areas to allow inter-area communication to occur.

• ASBR Summary LSA (Type 4) – Generated by ABRs in OSPF, and contains a route to any ASBRs in the OSPF system. Type 4 LSAs are sent from an ABR into its local area, so that Internal routers know how to exit the Autonomous System.

• External LSA (Type 5) – Generated by ASBRs in OSPF, and contain routes to destination networks outside the local Autonomous System. Type 5 LSAs can also take the form of a default route to all networks outside the local AS. Type 5 LSAs are flooded to all areas in the OSPF system.

OSPF Router Roles in Multi Area

Routers within a multi-area OSPF network fall into different categories.  OSPF Multi Area
1. ABR (Area Border Router) : To be a ABR router, it's minimum sigle interface of router must be in area 0.
2. ASBR (Autonimous System Border Router) : when a single router is connected with different routing protocol is called ASBR.
3. Backbone Router : Router inside area 0 are called Backbone Router.

Note: Area 0 is called Backbone area and other area are called regular area. When routing is performed and data is travelled, date communication only can happen through area zero "0" so it is called backbone router and all regular area must be connected to backbone area for data communication.

OSPF Neighbourship States

When OSPF routers are initialized, they first start exchanging information using the Hello protocol via the multicast address 224.0.0.5. After the neighbor relationship is established between routers, the routers synchronize their link-state database (LSDB) by reliably exchanging LSAs. They actually exchange quite a bit of vital information when they start up. The relationship that one router has with another consists of eight possible states. All OSPF routers begin in the DOWN state, and if all is well, they’ll progress to either the 2WAY or FULL state with their neighbors.

1. Down : When no OSPF is running.
2. INIT : In this state R1 sends hello but did not recived from R2.
3. Two Way : Both send and receive hellos. DR and BDR election will occur in this state. DR(Designated router) condition - Highest priority is consider but default is 1 in ospf and if tie highest router id is considered. BDR(Backup Designated router) - second highest router id will become BDR. Neighbourship performed.
4. Exstart : Master and slave election will occur in this state. Master will exchange update first and slave will receive and so on.
5. Exchange : Master will exchange brief summary description to its remote router.
6. Loadong : Actual update exchange willl perform.
7. Full : Adjcency done.

OSPF Basic Multi-area Configuration

 OSPF Multi Area Configuration
R1 configuration:
r1#config t
r1config)#router ospf 1
r1(config-router)#router-id 1.1.1.1
r1(config-router)#network 10.10.0.0 0.0.255.255 area 0
r1(config-router)#network 172.16.10.0 0.0.0.3 area 1
r1(config-router)#network 172.16.10.4 0.0.0.3 area 2

Here is the configuration for the R2 and R3 routers:

r2(config)#router ospf 1
r2(config-router)#network 0.0.0.0 255.255.255.255 area 2

r3(config)#router ospf 1
r3(config-router)#network 10.10.0.0 0.0.255.255 area 1
r3(config-router)#network 172.16.0.0 0.0.255.255 area 1