Configure WLAN using WPA2 PSK using the GUI | Practonet

Configure WLAN using WPA2 PSK using the GUI



We will follow above topology to configure WLAN using WPA2 PSk, Complete these steps in order to configure a WPA2 PSK in the WLC GUI:

1. Navigate to Configuration > Wireless > WLAN > WLANs, and create a new WLAN:


2. Enable WPA2, and map it to the desired interface:


3. Click the Security tab, check the WPA2 Policy checkbox, and select AES as the WPA2 Encryption. In the Auth Key Mgmt drop-down list, select PSK. Enter the PSK that the client will use in order to connect:


WPA2-PSK Configuration with CLI

This is the procedure to use the command-line interface (CLI) in order to configure DHCP snooping for the VLANs that are used for clients. VLAN20 is used for clients and the pool is configured on the same WLC. The TenGigabitEthernet1/0/1 from the Cisco 5700 WLC is connected to the uplink switch. If the DHCP server is configured on the server beyond the WLC or on an external DHCP server, you must trust DHCP snooping and relay information.

ip device tracking
ip dhcp snooping vlan 12,20,30,40
ip dhcp snooping
!
ip dhcp pool vlan20
network 20.20.20.0 255.255.255.0
default-router 20.20.20.1

interface Vlan20
ip address 20.20.20.1 255.255.255.0

interface TenGigabitEthernet1/0/1
switchport trunk native vlan 12
switchport mode trunk
ip dhcp relay information trusted
ip dhcp snooping trust

wlan wpa2psk 1 wpa2psk
client vlan 20
no security wpa akm dot1x
security wpa akm psk set-key ascii 0 Cisco123
no shutdown